FP TICO-Manual -DE

TICO - FP TiXML Console
User Manual

© 2019 -2020 FP InovoLabs GmbH
www.inovolabs.com
Publication close: 27.10.2020
This manual is protected by copyright. Any further sale is prohibited without the consent of the publisher. This applies in particular to
copies, translations, microfilm copies and the storage and processing on electronic data processing systems.
Various registered trademarks, company names and brand names appear in this handbook. Even if they are not designated as such,
the relevant proprietary rights still apply.

2

Table of content
1

ABOUT THIS DOCUMENT ..................................................................................................... 3

2

OVERVIEW ........................................................................................................................... 3

3

SYSTEM REQUIREMENTS...................................................................................................... 3

4

THE USER INTERFACE ........................................................................................................... 4

4.1
The Main Screen .................................................................................................................................. 4
4.1.1 The Source Window............................................................................................................................... 4
4.1.2 Parser View / Project View .................................................................................................................... 4
4.1.3 The Logging Window ............................................................................................................................. 5
4.1.4 The Command Window ......................................................................................................................... 5
4.1.5 „Test Templates“Menu.......................................................................................................................... 6
4.2
The Menu Bar ...................................................................................................................................... 7
4.2.1 The [Project] menu ................................................................................................................................ 7
4.2.2 The [File] menu ...................................................................................................................................... 8
4.2.3 The [Port] menu..................................................................................................................................... 8
4.2.4 The [View] menu ................................................................................................................................... 8
4.2.5 The [Logging] menu ............................................................................................................................... 9
4.2.6 The [Tools] menu ................................................................................................................................... 9
4.2.7 The [Settings] menu .............................................................................................................................. 9
4.2.8 The [Help] menu .................................................................................................................................. 10
4.3
The Button bar................................................................................................................................... 11
4.3.1 [Test] .................................................................................................................................................... 11
4.3.2 [Check] ................................................................................................................................................. 11
4.3.3 [Send]................................................................................................................................................... 11
4.3.4 [Break] ................................................................................................................................................. 11
4.3.5 [Save] ................................................................................................................................................... 11
4.3.6 [Offline]................................................................................................................................................ 11

5

FP GATEWAY REMOTE ACCESS........................................................................................... 12

51.0058.9213.01 Rev.00

TICO - FP TiXML Console – User Manual

About this document

1 About this document
This manual describes the elements of the TiXML-Console and their operation, which allow control
and configuration of the FP Gateway / Tixi Data Gateway (in the following named “FP Gateway”).
In chapter 4.1 the individual windows of the TiXML-Console are described, while chapters 4.2 and 4.3
cover the menu bar and buttons.
You’ll find some examples projects in the “examples” directory of your TICO installation. A description
of these examples can be found in the TiXML-Tutorial manual within the program group.
TiXML and the structure of the FP Gateway databases are described in the TiXML-Reference manual
which can be found in the program group too.

2 Overview
The TiXML-Console is a PC-based application for controlling and configuring FP Gateways. Due to mutual
dependencies between different sections of the configuration database, it's most recommendable to
create this configuration step by step - ISP access data, recipient addresses for alert messages, text of
these messages etc.
The TiXML-Console provides an easy-to-use interface for transmitting the appropriate data to the
device. The database sections are clearly arranged and their syntax will be checked automatically. This
allows the configuration of FP Gateways even without special knowledge of XML.
Controlling FP Gateways becomes much easier by the set of pre-defined command templates, which
can be easily accessed by a separate window. The incorporated editor allows editing these templates in
any way and sending them to the FP Gateway by a mouse click.
The compliance to the XML syntax will be ensured by the built-in syntax checker in order to minimize
error messages and loss of time by typing errors.

3 System Requirements
Operating System:

Windows 2000, XP, 2003, 7, 8, 10

Hardware:

Pentium-Prozessor with minimum 800 MHz, FP Gateway or Tixi Gateway,
one free RS232 interface or IP connection (LAN / WiFi).

Notes:

To display XML code correctly, the installation of Internet Explorer version
5.5 (or above) is necessary.
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4 The User Interface
This chapter describes the elements of the user interface along with their functions.

4.1 The Main Screen
After starting the TiXML-Console the main screen opens, along with a small „Command window“ as
shown below. The main screen is divided into three parts:

Main
screen

Parser
View /
Project
View

Source
Window
Command
Window

Logging
Window

4.1.1 The Source Window
The Source Window holds the configuration "source code" which will be transmitted into the FP
Gateway.
If requested, text may be edited inside this window and even whole XML documents may be inserted
from ASCII files. This window displays the templates from the Command Window as well, before they
are sent to the FP Gateway.
When a complete database is loaded either from disk or from the FP Gateway, its contents will be
displayed on register sheets. Even this display lets you edit the text.

4.1.2 Parser View / Project View
As soon as data is sent from the TiXML-Console to the FP Gateway, a reply message will be ejected. This
may be a result code, an error message, notification about mail sent or even database sections read
from the FP Gateway. In case of XML syntax errors, these will be reported in the Parser View as well.
All output to the Parser View becomes XML formatted, so tags can be easily distinguished from actual
data. The right mouse button opens a context menu which provides an option to show the source
code.

51.0058.9213.01 Rev.00

TICO - FP TiXML Console – User Manual

The User Interface
If you load a complete configuration from hard disk or modem, a new register „Project View“ will be
added to the Parser View. On switch to this register a list of all existing project databases is shown.
Clicking on one of these entries will show its database in the Source Window for further modifications.
Switching between databases automatically writes the changes into the project file.

Right click on an entry in the Project View opens a context menu to remove the marked database from
the project. The database will be hidden and may later be added back to the project with its old
content.

Please notice, that hidden databases are not transferred to the modem!

4.1.3 The Logging Window
All status messages, actions and the complete data traffic of the TiXML-Console will be logged and
displayed here. Error messages, notifications and data transmitted is backed with different colors:
Grey:
Gateway => Konsole

Green:
Konsole => Gateway

Red:
Error messages

White:
Separator

It is not possible to copy text from this window. You may access the complete logging info by using the
logging option of the menu bar. It allows saving the whole logging into an ASCII file and is described in
chapter 4.2.5 of this manual.

4.1.4 The Command Window
In the Command Window you'll find the most common commands necessary for control and
configuration of the FP Gateway. You’ll find them separated into themes.
Commands are shown with [ ].
Parameters are shown with < >.
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By double-clicking an entry, its complete XML syntax will be copied into the Source Window. Note that
commands identified by square brackets will overwrite the Source Window content while entries
marked by "<>" will be inserted at the current cursor position.
When using FP Gateways in Test-Mode (see chapter 4.3.1 of this manual), the Command Window
holds the Event Messages that allow testing the event processing of FP Gateways.
Double-clicking an entry inside the Command Window inserts the appropriate XML code at the
current cursor position in the Source Window. A description of syntax and purpose of the entries
inside the Command Window can be found in the TiXML-Reference Manual.
To switch the display of the Command Window on or off, use the menu bar option [View] >
[Command Window].

4.1.5 „Test Templates“Menu
In order to ease testing and configuration, you may even create and edit your own templates in the
Command Window, at least as long as the TiXML-Console is in Test Mode.
Activate that Mode (by clicking on the [Test] button). In the Command Window, you'll now find a
"Test Templates" option. It lets you choose from:
New
Create new templates here. These are the opportunities:
Empty
Creates an empty entry in the list of templates which can be named and edited at random.
Read Logfile creates a new entry with the command to read a Logfile. Only the logfile name
and range must be specified.
Event (with Parameter)
Creates an entry that holds predefined syntax for an event message, including parameter
templates which just need to be completed.
Event (no Parameter)
Does the same as the "Event" above, but no parameter placeholders are generated. Use this
for making Events without parameter.
Set Variable Bus
Creates an entry that holds predefined syntax for setting a variable value. Only the variable
path and value must be specified.
Clone
Highlight one template and use this option to create a copy of it with a new name. After
changing the text inside the Source Window, it can be saved to the Command Window by
clicking the [Save] button.
Rename
This option renames the template currently highlighted. Note that it must not be empty therefore.
Delete
Use this option to delete the template currently highlighted.
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4.2 The Menu Bar
This chapter describes the options to be found at each menu entry.

4.2.1 The [Project] menu
New:
Choose this option, if you want to create a complete empty project template.
We recommend using the next option in order to get an empty project with already build up
database structure. It helps you to save time writing all databases.
Open from Tixi device:
This lets you read an entire project (complete database) from the FP Gateway and display it in
the Source Window. The different database sections will be displayed on separate registry
sheets.
A TICO-Projekt consists of a file with “.tico“ extension (in older versions „.cnf“) and a same titled
directory containing different databases within text files.
Open from File:
This lets you read an entire project (complete database) from a project file on disk and display it
in the Source Window.
„.tico“ project files may be opened by double click too.

Close:
Close the currently opened project. You need to do this before opening another project.
This option is not available during “Test-Mode” (see chapter 4.3.1).
Save:
The currently opened project will be saved as a project file to the hard disk, from where you
may re-load it at any time (see above).
Note that if a project already exists by the same filename, it will be overwritten.

Save as:
The currently opened project will be saved as a project file with new filename to the hard disk,
from where you may reload it at any time (see above).
Send:
This sends all configuration data to the FP Gateway that has been edited and not yet sent to the
device.
Send all:
This sends all configuration data to the FP Gateway, regardless if altered or not.
A progress bar below the right window will show you the upload status.
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Import TILA project:
Converts a TILA2 project file (*.TiXML extension) to a TICO project file.
List:
As soon as a project is saved or loaded, a new entry will be made in the recent file list. There
you will have quick access to the last four projects.
Exit:
Click this option to shut down the TiXML-Console.

4.2.2 The [File] menu
Open:
Use this option to load an ASCII file from the hard drive. Its content will be displayed inside
the Source Window from where it can be transmitted to the FP Gateway.
This is useful in case your configuration consists of separate text files for each database
section.
Save:
This saves the Source Window content into an ASCII file. Use this option to quickly make a
backup of data read from the FP Gateway before altering these data.

4.2.3

The [Port] menu

Here you can select which COM port (RS232 interface) FP Gateway is connected to. An automatic
process will find the device automatically if you're not sure about the COM port.
A selection of the interface is only possible, if TICO is „offline“ (see chapter 4.3.6).
COM 1...COM 16:
Once you know which COM port the FP Gateway is connected to, select it here.
This option is only useful for older FP Gateways. Modern FP gateways are configured via TCP/IP.
TCP/IP:
Use this option to connect to a FP Gateway via TCP/IP. This can be done via LAN or Internet (the
PC and the FP Gateway have to be „online“).
The TCP/IP settings are described in chapter 4.2.7.
Auto:
Use this if you're not sure about the COM port, as the TiXML-Console will then search all COM
ports for a FP Gateway and will use the one where it's actually connected to.
This option is only useful for older FP Gateways. Modern FP gateways are configured via TCP/IP.

4.2.4 The [View] menu
Here you can affect the appearance of the TiXML-Console. The [Command Window] and
[Logging Window] options will switch the display of these windows on or off.
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4.2.5 The [Logging] menu
Logging:
This option switches the logging to an ASCII file on or off.
File Name:
Here you can provide a file name for the log file.

4.2.6 The [Tools] menu
Switch Mode:
This allows you to switch between Modem Mode and TiXML Mode. While in TiXML Mode, you may
control and configure FP Gateway by means of the TiXML-Console, so it will react on TiXML
commands and process events.
In Modem Mode you may use the FP Gateway as a common modem; this Modem Mode will be
signalled by the Modem Mode LED (on the device) lit.
In Modem Mode the Device doesn’t react on TiXML-Commands.
Wait for Client (TCP/IP):
If you have problems using TICO, the customer support may remote control your TiXMLConsole. Enable this option to allow remote access.
Remote Connect / Disconnect:
TICO offers remote access to FP Gateways. With this menu option you can use a common
modem to dial into a remote FP Gateway. See chapter 5
This option will be renamed into “Disconnect” during an active connection.
Set Process RUN/STOP:
This option allows starting (RUN) and stopping (STOP) the job processing of the FP Gateway.
On transmission of large projects an interrupt of the job processing is necessary similar to a PLC
RUN/STOP. This is automatically done by TICO during transfer of complete projects. If you
update single databases, you may switch the device state manually.

4.2.7 The [Settings] menu
Baudrate:
This option defines the baudrate between TICO and the FP Gateway. Products of the Hx100/400
series require 115200bps.
This option is only useful for older FP Gateways. Modern FP-Gateways are configured via TCP/IP.
TCP/IP:
This option opens the TCP/IP configuration to define the remote FP Gateway
address and Winsock-Port for TiXML-Communication:

51.0058.9213.01 Rev.00

TICO - FP TiXML Console – User Manual

9

10

The User Interface

Font:
We recommend to use a fixed width character font like „courier new“ which makes the
source code more comfortable to read.
Properties
The properties are used to adjust COM port timings and template versions.
The COM Port Delay defines how many milliseconds TICO will wait after opening the port. This
may be required on notebooks with COM ports power saving.

The Template Version specifies the project structure in the FP Gateway. FP InovoLabs
periodically releases new Firmware versions with new functions which may require new
commands and registers to be merged or added. To prevent compatibility issues the chosen
template version has to match the firmware version of the device.
To modify projects created by TILA, the template version must be set to „FW = 2.0 (TILA)“.

4.2.8 The [Help] menu
About TICO TiXML Console:
The version information of TiXML-Console.
Help:
Opens this manual.
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4.3 The Button bar
The button bar provides you with the most important tools needed for common
operations. This holds a display as well which informs you about the status of data
transmission from or to the FP Gateway.

4.3.1 [Test]
Switch the FP Gateway into Test Mode here, in case a project is loaded. You may not
configure anything in this mode but events may be triggered. In this mode, the FP
Gateway reacts as in "normal operation" so you can check your configuration for
proper operation.
In order to edit the configuration, you'll need to switch off the Test Mode.
The current status is signalled by the color of the [Test] button, which is yellow
when active. The Source Window remembers its last data, therefore you may switch
between both modes.

4.3.2 [Check]
Use this button to check the XML syntax of the current Source Window content. Therefore, the source
code will be displayed as formatted XML document inside the Parser View. As this is possible with
error-free source code only, typing errors will be spotted at once. As the error message displays a line
number, you may find and terminate the error quickly.
Note that the [Check] Button checks the XML syntax only. The correct spelling of TiXML commands
is not affected by this.
This button is only available if the „Parser View“ register is active.

4.3.3 [Send]
This sends all configuration data to the FP Gateway that has been edited and not yet sent to the
device. If no database is opened, the current Source Window content will be sent. This button only
works if a FP Gateway is connected to the TiXML-Console.
A progress bar below the right window will show you the upload status.
To send the entire configuration at once, use the menu option [Project] > [Send]

4.3.4 [Break]
In case the data transfer between FP Gateway and console is broken for any reason, you may stop it
by use of this button. If either the TiXML-Console or the device holds an incomplete configuration, this
can be corrected by simply reloading the data. By manually breaking the transmission, neither data will be
lost nor the device or its firmware will be damaged.

4.3.5 [Save]
This button does the same as the menu option [Project] > [Save] - it saves the entire
configuration to disk. The file name to be used is displayed in the TiXML-Console caption bar.

4.3.6 [Offline]
If you want to edit the project data only or if no FP Gateway is connected, use this mode. The TiXMLConsole will not try then to detect a FP Gateway and doesn’t block the COM port. Configuration data may be
loaded, altered and saved to disk.
Switching to offline mode is necessary before you change the COM port.
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5 FP Gateway remote access
The TiXML-Console offers remote access to a FP Gateway using a common modem. Use menu option
[Tools] -> [Remote Connect] to open the remote connect window:

Phone number:
Enter the phone number of the remote FP Gateway including all prefixes. A list of the ten last
dialled numbers is available.
Init command (optional):
Here you may enter special AT commands to initialize your local modem.
Dial options:
Modem parameters like pulse/tone dialling or waiting for dial tone may be activated here.
Login:
If the remote FP Gateway is protected with user name/password, you have to enter the correct
data in these fields.
Activate „keep password“ If you want to keep the user details together with the last 10
numbers.
„Delay after CONNECT(s)“ may be necessary for GSM providers which send the CONNECT
message to early. Delays between 1 and 5s are usefull.
The option „Protocol in „RemoteConnect.txt“ (yes/no)“ logs the communication into a txt-file. This
may help you to find communication problems.
The button [Connect] lets the modem dial into the FP Gateway. You will get an acknowledge as
soon as the connection is established, or an error if it is failed. The button [Cancel] interrupts the
dialling.
To disconnect the remote session you have to use the menu option
[Tools] -> [Disconnect]
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